Forum Discussion

Matthew_G's avatar
Matthew_G
Icon for Advocate I rankAdvocate I
2 years ago
Solved

Change semantic model size from small to large

Hi,   When creating a Warehouse a semtic model is created by default for that warehouse. I ran into a problem where the semantic model was no longer refreshing because it was too large. In the Work...
  • Matthew_G's avatar
    Matthew_G
    2 years ago

    Hi AndyDDC , I noticed that although new data was being imported into the fact table in the warehouse the data was not being refreshed/updated in the PBI report. It is a direct lake connection with no other imports. When I go to the refresh history under the semantic layer settings I get the following error:

    An error has occurred while framing the dataset ########-####-####-####-########### error: Microsoft.AnalysisServices.OperationException: Failed to save modifications to the server. Error returned: 'Resource Governing: This operation was canceled because there wasn't enough memory to finish running it. Either reduce the memory footprint of your dataset by doing things such as limiting the amount of imported data, or if using Power BI Premium, increase the memory of the Premium capacity where this dataset is hosted. More details: consumed memory 0 MB, memory limit 25600 MB, database size before command execution 33078 MB. See https://go.microsoft.com/fwlink/?linkid=2159753 to learn more. '. at Microsoft.AnalysisServices.Tabular.Model.SaveChangesImpl(SaveFlags flags, Int32 maxParallelism) at Microsoft.ASWL.Service.Engine.SeethruAutoSync.SeethruAutoSyncManager.<InvokeFramingAsync>d__32.MoveNext() in /_/ASWL.Service/Engine/SeethruAutoSync/SeethruAutoSyncManager.cs:line 0.

    I created a new warehouse that has the large semantic model by default, copied the data over to the new warehouse and was then able to connect and refresh the reports without issue. I assume that the small semantic model could not be refreshed due to a size limitation.