Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
VincentMeyers
Frequent Visitor

Data Pipeline stuck at start after fabric capacity change

Hello everyone,

 

I have several data pipelines and other farbic stuffs in 3 workspaces (bronze-silver-gold). Everyhing was working fine in my Trial capacity.

2 days ago, we decided to go in production, and assigned the 3 workspaces to our F4 capacity.

Some pipelines were not able to finish before the capacity was paused, while the duration in the Trial capacity was 3 minutes.

The pipelines were in "running" state, while the capacity was suspended (still 5 hours after).

 

We then decided to swap back to our trial capacity.

24 hours later, we are still not able to start any datapipeline in the gold workspace.

The first step of our "main" datapipeline is a variable initialisation, and this step is always stuck in "running" state four hours.

 

VincentMeyers_0-1717046376536.png

 

 

VincentMeyers_1-1717046385946.png

 

VincentMeyers_2-1717046436921.png

 

 

Can someone help with this please ?

1 ACCEPTED SOLUTION

Hello,

 

Than you for your feedback.

I recreated a new Capacity in Azure, and assigned all my workspaces to that new capacity (same SKU = F8).

Problem solved.

I kept the "corrupted" capacity and workspace for "corruption demonstration" needs, but this is clearly a bug.

 

Kr,

 

Vincent

View solution in original post

8 REPLIES 8
VincentMeyers
Frequent Visitor

Thx for your feedback.

 

More information from my side : It's not only the pipelines taht are stuck. For example, when I try creating a DataflowGen2 in that workspace, it's stuck on this : 

 

VincentMeyers_0-1717133070647.png

 

 

No answer after a few minutes. I think it's the whole workspace that is lost somewhere (I guess because the capacity swap).

 

 

Hi @VincentMeyers 

 

Apologies for the inconvenience.

There might be a chance of an intermittent issue could you please follow the below steps that might help you.

Temporary Glitch: Clearing cookies and caches can sometimes resolve temporary glitches within the application that might be causing the issue.

Corrupted Data: In rare cases, corrupted data stored in the browser's cache related to Microsoft Fabric might be causing the issue. Clearing the cache removes this potentially problematic data.

Hard Refresh: A hard refresh bypasses the cached version of the webpage and forces the browser to download the latest version from the server. Press Ctrl+Shift+R (Windows) or Cmd+Shift+R (Mac).

Try Microsoft Edge: If you are currently using Chrome or Firefox, try switching to Microsoft Edge to see if the issue persists. Edge is the native browser for Microsoft products and might have better compatibility with Microsoft Fabric.

 

If the issue still persists, please do let us know. Glad to help.

 

I hope this information helps.

Hello,

 

I tried on 3 different laptops, and different browser : still the same.

Since today, I'm able to create new artifacts, like pipelines and dataflow, but they are always stuck at start. And this happen only in this specific workspace.

 

See for example :

 

VincentMeyers_0-1717183101129.png

 

 

A new pipeline with a single step : initializing a variable. Stuck on "Running".

 

I have a lot of stuffs in that workspace, and my customer is waiting for it... :-(.

 

I hope someone can help me ! 🙂

Still the same status after 60 hours... The workspace is totally unusable...

Hi @VincentMeyers 

 

Apologies for the delay in response.

Just checking back to see whethe the issue still persists, In case if you have any resolution please do share that same with the community as it can be helpful to others.
Otherwise, will respond back with the more details and we will try to help.

 

If the issue still persists. Please reach out to our support team to gain deeper insights and explore potential solutions. It's highly recommended that you reach out to our support team. Their expertise will be invaluable in suggesting the most appropriate approach.

Please go ahead and raise a support ticket to reach our support team:

https://support.fabric.microsoft.com/support

After creating a Support ticket please provide the ticket number as it would help us to track for more information.

 

Thank you.

Hello,

 

Than you for your feedback.

I recreated a new Capacity in Azure, and assigned all my workspaces to that new capacity (same SKU = F8).

Problem solved.

I kept the "corrupted" capacity and workspace for "corruption demonstration" needs, but this is clearly a bug.

 

Kr,

 

Vincent

Hi @VincentMeyers 

 

I will reach out to the internal team regarding the bug and thank you for sharing the details.

 

Thank you.

v-cboorla-msft
Community Support
Community Support

Hi @VincentMeyers 

 

Apologies for the issue you are facing.
At this time, we are reaching out to the internal team to get some help on this. We will update you once we hear back from them.

Appreciate your patience.

 

Thanks.

Helpful resources

Announcements
FabricCarousel_June2024

Fabric Monthly Update - June 2024

Check out the June 2024 Fabric update to learn about new features.