Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
MonztaInc
Frequent Visitor

Cannot find supported delta type for logical type TimeSpan

Hello

 

Trying to use Copy Activity to copy data from Azure SQL Server to DataLake via Pipeline. 

Most of the tables are successful but some failed with the following error: 


Activity failed because an inner activity failed; Inner activity name: Copy_s2q, Error: ErrorCode=DeltaNotSupportedLogicalType,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=The logical type TimeSpan is not supported in Delta format. Reason: Cannot find supported delta type for logical type TimeSpan,Source=Microsoft.DataTransfer.ClientLibrary,'

 

Any ideas on where to start looking to troubleshoot?

 

Output from CopyActivity:

 

{

"copyDuration": 9,

"errors": [{ "Code": 21450, "Message": "ErrorCode=DeltaNotSupportedLogicalType,'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,Message=The logical type TimeSpan is not supported in Delta format. Reason: Cannot find supported delta type for logical type TimeSpan,Source=Microsoft.DataTransfer.ClientLibrary,'", "EventType": 0, "Category": 5, "Data": {}, "MsgId": null, "ExceptionType": null, "Source": null, "StackTrace": null, "InnerEventInfos": [] } ],

"usedDataIntegrationUnits": 4,

"usedParallelCopies": 1,

"executionDetails": [{ "source": {"type": "AzureSqlDatabase","region": "North Europe" },

"sink": { "type": "Lakehouse" },

"status": "Failed",

"start": "7/11/2023, 12:33:06 PM",

"duration": 9,

"usedDataIntegrationUnits": 4,

"usedParallelCopies": 1,

"profile": { "queue": { "status": "Completed", "duration": 6 }, "transfer": { "status": "Completed", "duration": 3 } },

"detailedDurations": { "queuingDuration": 6, "transferDuration": 3 } } ],

"dataConsistencyVerification": { "VerificationResult": "Unsupported" }

}

 

 

3 REPLIES 3
GraceGu
Employee
Employee

Would you mind filling a support case for this? We'll need engineering to track this one down. Thank you!

Hi there,

 

Did this issue ever get looked at as I've hit the same error with a 'Timespan' source column.  Even if try to cast the column as a varchar or even remove the Timespan column from the SELECT statement, I still hit the same error:  "Cannot find supported delta type for logical type TimeSpan"

Hey there DaveM92, 
After chatting to the support team, they advised mapping the data type to a 'string' as part of the initial load. 

 

In the copy wizard, on the mapping tab, I manually assigned the data type. Thankfully I only have 3 tables that this affects, so not a train smash, but not ideal either. 

 

Monzta_0-1709910593897.png

 

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayFBCUpdateCarousel

Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.