Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
PBI-Curious
Resolver I
Resolver I

How to stop numbers from rounding in visual

PBI Community Good Day

 

Looking for a solution to prevent the numbers in the visual from rounding up. I would like the change to affect this visual only if possible. I have tried to change the formatting to decimal, but it  doesn't prevent the rounding.

 

 

klsmith_dnb_3-1622563958167.png

 

 

klsmith_dnb_0-1622563602022.png

klsmith_dnb_2-1622563632146.png

 

 

Much appreciate your help!

 

Thank you

 

1 ACCEPTED SOLUTION
Jihwan_Kim
Super User
Super User

Hi, @PBI-Curious 

Please try the below.

Change the display units to None.

 

Picture1.png

 

Hi, My name is Jihwan Kim.

 

If this post helps, then please consider accept it as the solution to help other members find it faster, and give a big thumbs up.

 

Linkedin: linkedin.com/in/jihwankim1975/

Twitter: twitter.com/Jihwan_JHKIM

If this post helps, then please consider accepting it as the solution to help other members find it faster, and give a big thumbs up.


Go to My LinkedIn Page


View solution in original post

9 REPLIES 9
NeilChadwick
Regular Visitor

Hi, am I doing something wrong? My visualisations looks like this and I cannot find a Data Tab option.

 

My version - 2.106.883.0 64-bit (June 2022)

 

NeilChadwick_0-1657623436484.png

Not under General either:

 

NeilChadwick_1-1657623496259.png

 

 

 

 

So does mine and I can't find it either. 

PBI-Curious
Resolver I
Resolver I

Jihwan Kim

Much appreciate your help.

Thank you!

Here is what I found. 

How do you stop Power BI from rounding?
 
 
Instead of changing decimal places in visuals, you can directly click the column in FIELDS pane and then change decimal places to 9 under Modeling option.
This worked for me very well. 

This visual panel must be from an older version of BI because mine doesn't look like that. This is what mine looks like. 

jack1e_0-1661457169058.png

 

Jihwan_Kim
Super User
Super User

Hi, @PBI-Curious 

Please try the below.

Change the display units to None.

 

Picture1.png

 

Hi, My name is Jihwan Kim.

 

If this post helps, then please consider accept it as the solution to help other members find it faster, and give a big thumbs up.

 

Linkedin: linkedin.com/in/jihwankim1975/

Twitter: twitter.com/Jihwan_JHKIM

If this post helps, then please consider accepting it as the solution to help other members find it faster, and give a big thumbs up.


Go to My LinkedIn Page


This does not help. My visualization does not look like yours. I do not see the Data Lab or the Display Units under Visual or General. 

jack1e_0-1661451281738.png

 

Cel87
Frequent Visitor

If you are doing this as a card, change the Callout value > Display Units to 'None' to give you the exact amount

 

Cel87_0-1710473710540.png

 

This does not prevent rounding.

Anyone else have any luck?

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.