Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Ability to Change A Slicer's Eraser Icon's Color

This one is pretty self-explanatory and one I think has been on here a couple times.


When we use custom colors the eraser icon doesn't always clearly show up and my customers seem inconsolable that they have to "de-select" their selections from within a slicer (since they think the eraser doesn't exist or went away--not sure which that case is, but that's neither here nor there). It'd be nice to just set the icon to Black or something--even if it wasn't full hex control/functionality like we've comes to love elsewhere within the software.







Status: New
New Member

I have the same problem

Regular Visitor

This is much needed. In many background colors it makes it extremly difficult to see the eraser icon. I would also extend this to the down carrot that allows you switch from List or Dropdown.

Helper III
  • As others mentioned. This is very much needed, in dark theme backgrounds these icons are not visible. 
New Member


As in example below, it would be very helpful to have the ability formatting the Eraser and the Arrow down button of the slicer's dropdown. Thank you!

Regular Visitor




I am having the same problem. Users do not even know these options are available unless they hover.

Advocate I

Or, even if the eraser and select boxes used the selected font color would help. Right?

Helper III

yes, I would think that this is an easy fix. Power BI we are waiting to have this easy fix implemented. Can you make it possible?

Thank you

Frequent Visitor

I cant believe this isnt an option yet 😞

Resolver I

One solutuion is to make the global change;

Head over to your Theme Customization, change the colour of "Second Level Element" which will change the coulour of Eraser, its a global change so it will apply across the report.

Helper III

Thank you @BiAnalyst  for your suggestion. It worked for me. 👍
The second-level element is found under Customize theme>Name and colors>Advanced