ericmarshall's avatar
ericmarshall
Frequent Visitor
3 years ago
Status:
Investigating

Unable to feed on-premises SQL-Server data into Lakehouse

Please advise specific instructions on how it is possible for data from an on-premises SQL server database to be fed into a Lakehouse.

When using Gen2 dataflow to connect to on-premises SQL server via a gateway (client using Power BI Premium), configuring a Lakehouse as the data destination does not work:



If I use a Gen1 dataflow to connect to the on-premises SQL server, and then reference the result of this dataflow using a Gen2 dataflow, interface (most of the time) allows for the Lakehouse to be assigned as the data destination, but then the Gen2 dataflow fails to refresh and gives the following error:

When above dataflow is referenced in a pipeline, the associated run fails and below error message is received:

 

Trying to connect to the on-premises SQL Server database via a pipeline does not appear to be an option as the only available connection method is "Basic" and there is no option to select the gateway.

 



3 Comments

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi  ericmarshall ,

     

    Given that it is still a preview feature, based on the error message you provided, Power BI is currently not supported at this time.

     

     

    Community Support Team_Caitlyn

  • Anonymous 

    Thanks for getting back to me. If you could please provide an update as soon as more information is available that would be great.

  • Anonymous's avatar
    Anonymous
    Not applicable

    Updating the Power BI Gateway solved the issue for me.