"The credentials provided for the AzureTables source are invalid"
I started encountering the same issue, where I get the following error when I try to refresh my dataset that pulls data from Azure Table storage.
| Message: | The credentials provided for the AzureTables source are invalid. (Source at https://****.table.core.windows.net/.) Table: ****. |
| Cluster URI: | WABI-CANADA-CENTRAL-redirect.analysis.windows.net |
| Activity ID: | d66cef4f-86c4-45a8-b1d3-1172888df0d7 |
| Request ID: | 09094c31-7e94-4aa9-df0e-76e246dca7d2 |
| Time: | 2018-07-29 05:56:43Z |
As described by kyr and lukedoolittle, I am able to refresh the data within PowerBI Desktop without any issues. I have re-entered my Azure Table Storage credentials numerous times, but the issue occurs when I try a manual refresh or a scheduled refresh.
The strange thing is the error does not occur right away - the refresh process runs for a while (15-30 minutes) before the error occurs; a full refresh typically takes 50-60 minutes for my dataset.
This had been working fine (daily scheduled refresh) for over 10 months, but stopped working on July 20 (as seen below).
Any suggestions/help on how to troubleshoot and resolve this would be greatly appreciated.
Cheers.
Mike