kyr's avatar
kyr
Frequent Visitor
8 years ago
Status:
Needs Info

"The credentials provided for the AzureTables source are invalid"

Hi,

I am geeting "The credentials provided for the AzureTables source are invalid error" while refeshing Power bi dataset in power bi online. Here my source is Azure Storage table and it is large data.If i am running same PBI file in my local desktop with same credntials it working but in power bi account (https://app.powerbi.com) refreshes are failing .Can anyone please help on this issue.

 

Thanks 

 

9 Comments

  • kyr's avatar
    kyr
    Frequent Visitor

    i am not using gateway.Power bi support Direct connection to Azure Storage table so i am using that.

    Can we have any other alternative way to debug this ?

  • Anonymous's avatar
    Anonymous
    Not applicable

    kyr,

    Please use Fiddler to collect log and share the log here.

    Regards,
    Lydia

  • I am seeing the same "The credentials provided for the AzureTables source are invalid error" but only on Azure Table Storage data sources. I have a SQL Data Warehouse and several local SQL databases, Google Analytics, etc, all of which refresh fine from the portal. Short Summary: If I refresh my report using PowerBI desktop it works as expected. If I upload that report to the portal and either use a manual refresh or a scheduled refresh I get the above error. I've tried manually editing the credentials in the portal, re-entering my key from the Table Storage in my Azure account but nothing changes.
  • mjensen's avatar
    mjensen
    Regular Visitor

    I started encountering the same issue, where I get the following error when I try to refresh my dataset that pulls data from Azure Table storage. 

     

    Message:The credentials provided for the AzureTables source are invalid. (Source at https://****.table.core.windows.net/.) Table: ****.
    Cluster URI:WABI-CANADA-CENTRAL-redirect.analysis.windows.net
    Activity ID:d66cef4f-86c4-45a8-b1d3-1172888df0d7
    Request ID:09094c31-7e94-4aa9-df0e-76e246dca7d2
    Time:2018-07-29 05:56:43Z

     

    As described by kyr and lukedoolittle, I am able to refresh the data within PowerBI Desktop without any issues. I have re-entered my Azure Table Storage credentials numerous times, but the issue occurs when I try a manual refresh or a scheduled refresh.

     

    The strange thing is the error does not occur right away - the refresh process runs for a while (15-30 minutes) before the error occurs; a full refresh typically takes 50-60 minutes for my dataset.

     

    This had been working fine (daily scheduled refresh) for over 10 months, but stopped working on July 20 (as seen below).

     

     

    Any suggestions/help on how to troubleshoot and resolve this would be greatly appreciated.

     

    Cheers.

    Mike

  • I get the exact same issue ! Is there somebody of Microsoft that could help here ?

     

    Thanks !

    Bertr

  • sandonet's avatar
    sandonet
    Regular Visitor

    I got this same issue in desktop app or in web app, need help here!

  • I know this thread is kind of old but anyone else that may have this issue, check the "Firewalls and virtual networks" in the Azure Account settings. Make sure the "Allow access from" radio button is checked to "All networks". The reason it works for desktop is because your client IP address is allowed but not the Power BI Service IP address.