patrickmaul's avatar
patrickmaul
Frequent Visitor
2 years ago
Status:
Done

Live connect to external data does not work anymore

I am an external consultant for a company and cannot access datasets from Power BI Desktop anymore.

I use my "personal" Power BI account to access the customer tenant. I have PPU licence. I can access the Portal and open reports there.

However, when I try to connect to a semantic model (via OneLake data hub -> Semantic Model -> External Data), I get an error

 

 

Error message: WAM Error Error Code: 3399614476 Error Message: (pii) Internal Error Code: 557973645
Correlation Id: 35ce846f-cd4f-4069-91fa-c90fb5f7fcbf
Time: 2024-09-13 13:12:45.112Z

 

 

Power BI tenant settings are correct, the semantic model has been shared with me and is accessable via portal. Also, it worked like 10 weeks ago, but I haven't worked with the data since then.

 

Please advice how I can proceed in this case.

 

Best regards 

Patrick

5 Comments

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi patrickmaul 

    So, you could go and connect to this semantic model on Desktop normally before, right? Now you can't access it in Desktop, can you still access the report in Service? You need to contact the creator or administrator of the semantic model to make sure you still have the current access rights.

     

    Best Regards,
    Community Support Team _ Ailsa Tao

  • patrickmaul's avatar
    patrickmaul
    Frequent Visitor

    The access rights haven't changed since the last time I worked with the data. However, I also checked them multiple times, and tried to have the semantic model shared directly with me, but still does not work.

     

    Does this WAM error usually result form changes in tenant settings, Azure or entra changes. Or is it from the local machine?

     

    Best regards 

    Patrick

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi patrickmaul 

    According to the error message, the problem is with your AAD account. Are you still able to use your account to create reports based on this semantic model on Service, and can you make sure you still have access to this data source? It's the data source where the semantic model gets its data.

     

    Best Regards,
    Community Support Team _ Ailsa Tao

  • patrickmaul's avatar
    patrickmaul
    Frequent Visitor

     

    Edit: It works now.  I don't really know how - I disconnected my Microsoft Businesse Account from windows, Edge and Office 365, logged in again and suddenly it works. Cannot state exactly if there was something in the background from my customer's IT department. But I will marked it as solved

     

     

    We checked the AAD/Entra and could not even see a login attempt from my account. We also re-installed Power BI and tried it from a different machine, but still no success.

    My user never hat direct access to the data source (which is SQL Server) - only via technical user. However, my user has access to the semantic model, which uses import mode. And as I said before, I can access it via service, but not via Power BI Desktop.

     

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi patrickmaul 

    Looks like it was a fluke, anyway, glad you got your issue resolved. You can continue to update this thread below if you have the same problem in the future. 

     

    Best Regards,
    Community Support Team _ Ailsa Tao