davenish's avatar
davenish
Regular Visitor
6 years ago
Status:
New

Keeping getting a credential issue with Personal Gateway

Tried a different workstation as the gateway and the issue persists, i've tried with a new PowerBI file and the issue persists

Any ideas how to fix?

{"error":{"code":"DM_GWPipeline_Gateway_SignatureNotMatchCredentialError","pbi.error":{"code":"DM_GWPipeline_Gateway_SignatureNotMatchCredentialError","parameters":{},"details":[],"exceptionCulprit":1}}} Table: Table1.


Thanks!

6 Comments

  • v-qiuyu-msft's avatar
    v-qiuyu-msft
    Icon for Community Support rankCommunity Support

    Hi davenish, 

     

    Did you run April release gateway? There is a known issue listed in Support site: 

     

     

    Best Regards,
    Qiuyun Yu 

  • davenish's avatar
    davenish
    Regular Visitor

    I tried rolling back to the March gateway, no change 😞

  • v-qiuyu-msft's avatar
    v-qiuyu-msft
    Icon for Community Support rankCommunity Support

    Hi davenish, 

     

    Did the issue occur when you refresh the dataset? 

    Which data source used in the dataset?

    How about the result after re-specifying data source credentials? 

     

    Best Regards,
    Qiuyun Yu

  • davenish's avatar
    davenish
    Regular Visitor

    Yes, the issue occurs when we refresh the data source and for scheduled refreshes

    Data source is on a local drive network drive

     

    How do  you respecify data source credentials?

     

    thanks!

    D

  • Anonymous's avatar
    Anonymous
    Not applicable

    davenish I had this issue with an excel file data source. These steps helped me.

     

    • Reinstall the personal gateway
    • Navigate to "Datasources >> Settings >> Data Source Credentials"
    • Clicked on Edit Credentials - no change in any connection settings/ other details

    That seemed to reset the sources to use the personal gateway I had (re)installed and scheduled refresh started working again.  

  • test00's avatar
    test00
    Regular Visitor

    Hi,

     

    I was struggling with the same issue. I went to the settings of the data source (semantic model on Power BI service) > data source credentials. I entered all the credentials and refreshed on Power BI service. Everything worked fine.