Gateway Error - Scheduled Refresh fails
For two weeks now, few of our published reports have failed to resfresh on the service with the same error -
Failure details: The last refresh attempt failed because of an internal service error. This is usually a transient issue. If you try again later and still see this message, contact support.
{"error":{"code":"DM_GWPipeline_Gateway_SpooledOperationMissing","pbi.error":{"code":"DM_GWPipeline_Gateway_SpooledOperationMissing","parameters":{},"details":[],"exceptionCulprit":1}}} Table:
We tried optimizing the report, restarted the GW VMs, resintalled/updated GW and we are still continuing to run into the same issue with no specific pattern across the failed ones as several other reports with the same source seems to update as usual. Please advise. Appreciate your help!!
4 Comments
- v-chuncz-msft
Community Support
Anonymous
The issue can be caused by the excessive memory footprint of the dataset. Try to reduce the data or implement incremental refresh.
- AnonymousNot applicable
For the reports in question, the size of the data is less than half a million rows while we have reports that are pulling in several million records running just fine. I am not sure that is the issue here.
- nickelousFrequent Visitor
We also started seeing an influx of these errors in the last 3 or so weeks.
These are reports that have worked for us for years, some that contain only one days (a few rows) worth of data.
- RubiRegular Visitor
I have the same issue since Tuesday night. The storage cannot be the Problem, I have checked that.
However, the same dataset and report is working in a premium workspace. But the pro workspace didn't have any issues for the past Months to update the data.
Have you found a solution?
Here you can see that the refresh stopped working suddendly.