Gateway Data Source Partially Online - Oracle
Hi rgupta25
You might encounter any of several errors from Oracle when the naming syntax is either incorrect or not configured properly:
- ORA-12154: TNS:could not resolve the connect identifier specified.
- ORA-12514: TNS:listener does not currently know of service requested in connect descriptor.
- ORA-12541: TNS:no listener.
- ORA-12170: TNS:connect timeout occurred.
- ORA-12504: TNS:listener was not given the SERVICE_NAME in CONNECT_DATA.
These errors might occur if the Oracle client either isn't installed or isn't configured properly. If it's installed, verify that the tnsnames.ora file is properly configured and you're using the proper net_service_name. You also need to make sure that the net_service_name is the same between the machine that uses Power BI Desktop and the machine that runs the gateway. For more information, see Install the Oracle client.
You might also encounter a compatibility issue between the Oracle server version and the Oracle Data Access Client version. Typically, you want these versions to match, as some combinations are incompatible. For instance, ODAC 12.x does not support Oracle Server version 9.
Manage your data source - Oracle - Power BI | Microsoft Learn
Ι have also found a similar post, please refer to it to see if it helps you.
Solved: Re: New Error ORA-12154 TNS:could not resolve the ... - Microsoft Power BI Community
Best Regards,
Community Support Team _ Ailsa Tao