mmerchak's avatar
mmerchak
Icon for Advocate II rankAdvocate II
2 years ago
Status:
Investigating

Frequent "Cache.Key is denied" Refresh Failure on Service

Our gateway is up to date (we just updated a few days ago) and I have been having this issue since the March gateway update. Random reports will frequently get this refresh error during it's scheduled refresh in Power BI service. This error is not consistent. For example, a 9:00am refresh completed without issue and then an 11:00am refresh failed with this error:

 

{"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"<ccon>An error happened while reading data from the provider: 'Access to the path 'C:\\Windows\\ServiceProfiles\\PBIEgwService\\AppData\\Local\\Temp\\Microsoft\\MashupProvider\\Cache\\Uzd@iy7VOEcSTQNocKkMETMMCDlJeLNn+iocalJLh2WI=\\Cache.Key' is denied.'</ccon>"}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourceKind","detail":{"type":1,"value":"SQL"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourcePath","detail":{"type":1,"value":"<ccon>rjc-sql3;BI_ReferenceTables</ccon>"}},{"code":"Microsoft.Data.Mashup.ValueError.Reason","detail":{"type":1,"value":"DataSource.Error"}}],"exceptionCulprit":1}}} Table: Safety Data.

 

I have tried researching this error and have gotten nowhere. Does anyone know why this is happening/how to fix it?

 

Thank you!

3 Comments

  • Anonymous -

     

    Thank you for your response! I reached out to my infrstructure team and they said that the only way to downgrade the gateway would be to delete it and set it up all over again. I don't want to have to set up all of my data sources again. Is there anything else you can recommend?

     

    Thank you!

  • The latest Data Gateway update seems to have fixed this issue for the most part!