Error when updating composite model credentials to another Power BI Dataset
Hi All,
Starting today we are experiencing issues when updating the credentials for a Power BI dataset in a composite model. When we try to re-enter the credentials we get the following error:
Failed to update data source credentials: AnalysisServices: Failed to resolve the core XMLA server
This only seems to happen when we publish a new dataset or try to re-enter the credentials on a published (composite) dataset which connects to an existing Power BI dataset (through the API endpoint). See below screenshot:
Furthermore I'm experiencing this issue on multiple Power BI tenants in the Western Europe region, there seems to be a change in the Service which I can't get my hands to.
Can anyone confirm this is a bug in the Power BI service so that we can get a fix from Microsoft?
Thanks in advance!
Kind regards,
Ron Verhoeven
57 Comments
- JustinKroppRegular Visitor
I am experiencing the same issue. https://wabi-west-us-redirect.analysis.windows.net/ here.
- v-cazheng-msft
Community Support
Status changed:NewtoInvestigatingHi Fenalytics,
We don’t see any statement or known issue said that it’s a bug. If this issue is urgent for you, you could consider submitting a support ticket in Power BI Support if you are a Pro user. Then, there will be a support engineer to help you troubleshoot on this issue.
The link of Power BI Support: Support | Microsoft Power BI
For how to create a support ticket, please refer to How to create a support ticket in Power BI - Microsoft Power BI Community
Best Regards,
Community Support Team _ Caiyun
- Fenalytics
Advocate III
We just submitted a pro-ticket, this is an issue for us (and probably much more people who use composite datamodels and try to update their credentials).
Since we cannot update our credentials, the scheduled refresh option from the interface is greyed out. This is a manual job now for us (we don't use the refresh API). - AnonymousNot applicable
Hi,
We have just started experiencing this error as well. Users have been able to establish, define credentials and setup refresh schedules on composite models using PBI datasets and they are no longer able to.
I will also create a pro ticket to raise visibility.Best regards,
Danilo
- Fenalytics
Advocate III
I got a response back from the MS-team (they are on it):
Failed to update data source credentials: AnalysisServices: Failed to resolve the core XMLA server
I would like to inform that, the issue is already reported to our product team, we will keep you posted as soon as we hear from them. - johnt75
Super User
I'm also experiencing the same problem
- AnonymousNot applicable
Fenalytics Great! Thanks for keeping us posted.
- proteantecs
Advocate I
Same here
- mshparber
Advocate I
I also have this problem. Noticed today
First I see this:
Then, when I edit credentials, I get the mentioned error:
Failed to update data source credentials: AnalysisServices: Failed to resolve the core XMLA server
- jitendrasinghRegular Visitor
I am also getting the same error, please post the solution if you find it 🙂