I think there may be a fundamental problem with the enteprise gateway. I have setup a brand new gateway and tried to create a datasource for the following URL's
https://www.google.com.au/?q=1
https://www.google.com.au/?q=2
I can only create a datasource for one of these, not both. When I try to do both I get a duplicate data source error. It looks like the enterprise gateway is stripping off the query string when checking for duplicates.
Unfortunately, this is a fairly serious limitation as when using Reporting Services (and most likely other web applications) much of the unique information is contained in the query string.
This has not been a problem in the past so looks like something that has recently been introduced.
18 Comments
- v-haibl-msft
Microsoft Employee
I can repro the same issue as you. I’ve reported it internally to Power BI Team: CRI 27641863
I’ll post here once I get any update for it.
Best Regards,
Herbert
- prestoFrequent Visitor
Thanks for your help. Hopefully we can get it resolved fairly quickly as we make extensive use of Reporting Services as a data source.
- Vicky_Song
Impactful Individual
Status changed:NewtoAccepted - Vicky_Song
Impactful Individual
Status changed:AcceptedtoNeeds Info - Vicky_Song
Impactful Individual
Status changed:Needs InfotoAccepted - engineerNew MemberNot sure if this is the same issue, please forgive me if this is not the right place to post. We're getting the same error, but the scenario is a little different: we have a SQL Server database that is currently in process of moving from development to production, and is now in testing on the production instance of SQL Server, preparatory to go-live. It still exists on the development server too. The database name is the same on both servers, but the server names are quite different. In this case we're running against the default instance on both servers. It looks to me as if the only thing the cloud service looks at is the database name, ignoring the server/instance name. Can this be correct? If so, can the team fix things so that distinct database instances on distinct servers can be recognized as distinct data sources? Thanks.
- v-haibl-msft
Microsoft Employee
When configure on-premises gateway, there is one field for server name and one field for database name as below.
Best Regards,
Herbert
- engineerNew Member@Herbert, Thanks, that's what we've been doing. Have you tried putting the same database name in that field for 2 data sources, while varying only the server field? Example: 1) Server: TestDBServer Database: Sales 2) Server: ProductionDBServer Database: Sales When we try this, the second data source cannot be created, because we get the error message "Duplicate data source." Are we doing something wrong, or is this a defect in Power BI?
- Vicky_Song
Impactful Individual
- PallichFrequent Visitor
Hi.
I have the same problem. ((
Please help.