DB2 support - Default driver not working
So, I looked further into this by tracing what registry keys the MS DB2 OLEDB Provider created during installation.
After some searching regarding Host Integration and Telemetry (the error being 'The type initializer for 'Microsoft.HostIntegration.Common.TelemetryCLient' threw an exception.'), I found that the installation of the DB2 OLEDB provider actually installs part of the Host Integration Server (made for integrating IBM server applications, e.g. DB2, with Microsoft Server products, https://docs.microsoft.com/en-us/host-integration-server/what-is-his).
Apparently the HIS includes a telemetry module to collect statistics, and in the documentation it says that the UI has an on/off toggle as well as a PowerShell way to toggle it.
So, I found the corresponding registry key that disables the Telemetry module i HIS, and voilá, now Power BI Desktop, Power BI Report Server works without error, even when the MS DB2 OLEDB-provider is installed.
The registry key to change is HKLM\SOFTWARE\Microsoft\Host Integration Server\Telemetry\Enabled which needs to be set from "true" to "false".
I understand that the problem is that the Telemetry module in HIS is dependent on a .NET library version that is not compatbile with the .Net version used be Power BI DB2-provider.
NB: Changing the registry key is of course not a Microsoft-supported fix, so use it if you (think) you know what you're doing. But it made my day finding it out at least.