Fabric offers the option to temporarily burst the capacity to max three times the power that is associated with the SKU.
This works fine, but at some point the overage needs to be burnt down, leading to throttling or even rejection.
I'd like to have the option to limit bursting or even turn it off to prevent the throttling and rejection all together. This would have an impact on the duration of interactive and/or background processes. Overall, I think it will lead to a better user experience when it's just clear that the chosen SKU is insufficient for that point in time and should be upgraded to a higher one. This is an easier discussion with a client than having to explain why there were error messages about the capacity 'not working'.
7 Comments
- fbcideas_migusrNew Member
A configurable parameter for bursting would be nice. For example x times bursting.
You're alone on the capacity because you're the sole dev? Set it to 10 and enjoy the speed!
You have to share a capacity globally and you don't want to borrow capacity from other time zones? Set it to 1 (which would mean no bursting).
- thisissanthoshr
Microsoft Employee
Thank you sharing this. For spark workloads I have included this to my list for the upcoming semester to make the burst factor configurable.
- dvnnaiduNew Member
This is a must and also there is a big in the bursting when pausing a capacity. When capacity is paused for that second consumption shows as in million of CUs
- fbcideas_migusrNew Member
Is not a rejection, but is a limit . . .
SKU Guardrail: Limit the burstable SKU escalation to a maximum
- thisissanthoshr
Microsoft Employee
Have added it to our backlog and this ask is under internal review. Stay tuned for updates. Thank you! - fbcideas_migusrNew MemberStatus added:Under Review
- AnonymousNot applicable
Thank you for this posting. We released a preview of Surge Protection that limit the allowed background usage. This can be used for the purpose of limiting bursting, since background requests can be rejected much sooner than the default configuration. Here's the link. Let us know if that's helpful for this idea or if there's more we should consider doing. https://blog.fabric.microsoft.com/en-us/blog/announcing-surge-protection-public-preview
Recent ideas
Deployment pipeline: Deployment rules for Direct Lake on OneLake semantic models
Currently, it is not possible to use deployment rules with Direct Lake on OneLake semantic models. The option is greyed out. Please enable this, so we can automatically change the data so...frithjof_v15 minutes agoCommunity ChampionNew6.2KViews143likes18CommentsOffice 365 Outlook Activity - Add Attachment (Pipelines)
I realize this is still in preview, but I would love to see the ability to add an attachment to an email within a pipeline using the outlook activity. Simple enough I would think, and perhaps it ...JenAbe3 hours agoAdvocate INew628Views6likes1CommentProvide Exactly-Once Triggering for OneLake File Events
Currently, a single completed OneLake file can generate duplicate events and trigger the downstream Fabric pipeline multiple times. Filtering on data.api = FlushWithClose helps identify completed fi...mahadev933 hours agoNew MemberNew6Views0likes1CommentNeed ability to retain URL filters and still have "Reset to default" available in Power BI Service
We have a customer scenario where reports are opened using Power BI URL filters to preselect values such as: &filter=Time_Period/Time Period eq 'Year to Date' and RLSVENDOR/MANUFACTURER_ID eq '7' T...swetha124 hours agoMicrosoft EmployeeNew47Views17likes0CommentsDatabricks connector should import column descriptions
It is possible to add comments/descriptions to databricks database **columns**, and in powerbi a column can have a column description which can pop up when hovering over the column name. When importi...Erik_Parmann4 hours agoNew MemberNew609Views24likes6Comments