Forum Discussion

Anonymous's avatar
Anonymous
Not applicable
10 years ago
Solved

Enterprise gateway "cannot connect to the mashup data source"

Hi, everyone,

 

I'm having trouble trying to migrate my data sources to the enterprise gateway.

 

The sql server connections have connected with no issues, however, when I try to connect a Mysql database and an excel file, I'm having this following error:

 

Unable to connect: We encountered an error while trying to connect to \\msjdb\Other_data\DimDate.xlsx. Details: "Cannot connect to the mashup data source. See error details for more information."Hide details
Activity ID:b1981927-e3f7-198a-b1ba-15ba98c77480
Request ID:1763c05f-277e-7bc8-7c74-57b6bc65eb86
Cluster URI:https://wabi-north-europe-redirect.analysis.windows.net
Status code:400
Error Code:DM_GWPipeline_Gateway_MashupDataAccessError
Time:Mon Mar 14 2016 14:54:22 GMT+0200 (FLE Standard Time)
Version:13.0.800.645
Underlying error message:We're sorry, an error occurred during evaluation.
DM_ErrorDetailNameCode_UnderlyingHResult:-2147467259
Underlying error code:-2147467259

 

Any help would be appreciated as the error is not clear to me.

 

Thank you.

  • Anonymous's avatar
    Anonymous
    10 years ago

    I've had the same issue and the fix for me was uninstalling the Personal Gateway or the Enterprise Gateway. I had both running and there seems to be a conflict if both programs are installed.

37 Replies

  • Anonymous's avatar
    Anonymous
    Not applicable

    I've had the same issue and the fix for me was uninstalling the Personal Gateway or the Enterprise Gateway. I had both running and there seems to be a conflict if both programs are installed.

    • jirineoral's avatar
      jirineoral
      Icon for Post Patron rankPost Patron

      I had same issue. Didn't occur to me that there could be conflict between two gateways. Thanks echofoxtrot. It releives a lot of pain

    • Anonymous's avatar
      Anonymous
      Not applicable

      Can you please share the steps, and what particular menus you went to, in order to uninstall the Personal or Enterprise Gateway?  I don't know where to start this process, if you can provide steps and menus...thanks.

  • dimazaid's avatar
    dimazaid
    Icon for Microsoft Employee rankMicrosoft Employee

    Thanks for reporting. We'll take a look.
    Could you send your Gateway logs to [email protected]. You can find your logs here: 

     C:\Users\PbiEGwService\Appdata\Local\Microsoft\Power BI Enterprise 

     

    • JonnaGalloway's avatar
      JonnaGalloway
      Regular Visitor

      Hi dimazaid,

       

      Apologies to jump onto this post but I have the same issue.

       

      Did you manage to get the bottom of this?

       

      I tried the potential solution mentioned below about uninstalling personal gateway and using the enterprice gateway, but it's still saying offline on the Power BI Manage Gateways area when trying to connect to MySQL hosted.

       

      Thanks

      • Anonymous's avatar
        Anonymous
        Not applicable

        For me the conflict between gateways was the issue.

        Did you make sure none of the data connections are missing from the gateway configuration within Power BI service? Or is it just the single MySQL connection within your report?

    • Noak's avatar
      Noak
      Icon for Helper IV rankHelper IV

      I have the same issue, did you find a solid solution?.

       

      dimazaid

    • Anonymous's avatar
      Anonymous
      Not applicable

      Hi dimazaid

      The solution for this post didn't work for me. I only have personal gateway installed. Is there any work around?

      Thank You

      • caslus's avatar
        caslus
        Icon for Helper I rankHelper I

        I believe I had the same problem

         

         

        No se puede conectarHemos detectado un error al intentar conectar con http://orbisolar.com.mx. Detalles: "No se pudo registrar este origen de datos para ninguna instancia de puerta de enlace en este clúster. A continuación encontrará más información sobre los errores específicos de cada instancia de puerta de enlace."Ocultar detalles

        Identificador de actividad:2b175acd-e92c-a3ff-488d-6ba8438edfeb
        Identificador de la solicitud:ef5bdac6-e4db-689d-453a-7dc16c13b7c1
        URI de clĂşster:https://wabi-south-central-us-redirect.analysis.windows.net
        CĂłdigo de estado:400
        CĂłdigo de error:DMTS_PublishDatasourceToClusterErrorCode
        Hora:Tue May 22 2018 18:17:48 GMT-0600 (Hora verano, Montañas (México))
        VersiĂłn:13.0.5314.162
        bi:No se puede conectar con el origen de datos del mashup. Para obtener más información, consulte los detalles del error.
        CĂłdigo de error subyacente:-2147467259
        Mensaje de error subyacente:MySQL: Unable to connect to any of the specified MySQL hosts.
        DM_ErrorDetailNameCode_UnderlyingHResult:-2147467259
        Microsoft.Data.Mashup.ValueError.DataSourceKind:MySql
        Microsoft.Data.Mashup.ValueError.DataSourcePath:http://orbisolar.com.mx;tickets
        Microsoft.Data.Mashup.ValueError.ErrorCode:-2147467259
        Microsoft.Data.Mashup.ValueError.Message:Unable to connect to any of the specified MySQL hosts.
        Microsoft.Data.Mashup.ValueError.Reason:DataSource.Error
  • Hello,

     

    I´m also having the same issue. 

    I´m trying to connect to a parvasive database through an ODBC (32 bits). I have tested that ODBC and it is working fine, but it is being impossible to use it in a new power bi data source. 

    I have tried to add an SQL Server data source, and there is not problem in this case. 

     

    Hope someone help me. 

    Thanks in advance.

    • JorgeDiego's avatar
      JorgeDiego
      Icon for Advocate I rankAdvocate I

      This is the error message that is being showed from Power BI:

       

      No se puede conectarHemos detectado un error al intentar conectar con Dsn=ALFA0000001. Detalles: "No se puede conectar con el origen de datos del mashup. Para obtener más información, consulte los detalles del error."Ocultar detalles
      Identificador de actividad: a1fd17e1-afba-4147-aa28-c8a2cc6d59ff
      Identificador de la solicitud: a2cff37a-2f46-6d02-4dac-6a2e460323cb
      URI de clĂşster: https://wabi-europe-north-b-redirect.analysis.windows.net
      CĂłdigo de estado: 400
      CĂłdigo de error: DM_GWPipeline_Gateway_MashupDataAccessError
      Hora: Tue Dec 27 2016 11:59:32 GMT+0100 (Hora estándar romance)
      VersiĂłn: 13.0.1700.866
      CĂłdigo de error subyacente: -2147467259
      Mensaje de error subyacente: ODBC: ERROR [IM014] [Microsoft][Administrador de controladores ODBC] La arquitectura del DSN especificado no coincide entre el controlador y la aplicaciĂłn.
      DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259
      Microsoft.Data.Mashup.ValueError.DataSourceKind: Odbc
      Microsoft.Data.Mashup.ValueError.DataSourcePath: dsn=ALFA0000001
      Microsoft.Data.Mashup.ValueError.Reason: DataSource.Error

       

      • heidibb's avatar
        heidibb
        Icon for Helper IV rankHelper IV

        I wanted to just respond to this for anyone that might be having this issue going forward. I was receiving the same error, seemingly out of the blue on a report that was running and refreshing just fine. I verified that the base tables all contained data.

         

        My connections are a few direct to a table and a few that I have a SQL query. I ran each of my queries in MS SQL to be sure all were running fine, and they were. I identified the table that was holding up the refresh in my desktop file, and tested making a small change to the syntax (removing distinct or removing order by). This seemed to have reestablished my connection and all connections refreshed just fine.

         

        So now I know how to fix this issue, but the gap is why the connection was lost in the first place? Maybe something on the business side with the actual server I'm connecting to? I'm not sure. But if this happens to you, maybe try testing a small syntax change to your query and see if that works for you.

  • Hi everyone!

     

    I'm facing a similar problem.

     

    I'm conected with an SAP Bussiness Warehouse Server, in which the data is stored in Cubes (MDX).

     

    After publishing my report, I had to stablish an On-Premisse Gateway, which after some headaches was conected

     

    Now, when I try to mix the dimensions and measures from the cube, it gives me the same message: "cannot connect to the mashup data source".

     

    This is a part of the message:

    ID da atividade74425664-f642-46e9-bae1-2d2bca184e06
    Solicitar ID87e821a7-97be-0982-04c4-87ddeae0d457
    ID de correlação6bb57f90-49b1-31c7-872d-4334e1c87e12
     
     
     
     
     
     
     
     
     
     
    I've already uninstalled my Personal Gateway to check if it would work, but no, it didn't changed much.
  • Anonymous's avatar
    Anonymous
    Not applicable

    Having this issue with an Enterprise Gateway. I removed a Personal Gateway (that had worked fine). The data sources in the Enterprise Gateway all connect without error yet the Datasets won't manually refresh or schedule refresh. Reports don't refresh either. I have to refresh everything from Desktop manually.

     

    It's a definite show-stopper.

     

    Any help from the technical team on this would much appreciated.

  • Hi guys!
    I've found the solution for me.
    I noticed that this problem appeared after adding the new server in our domain.
    So I decided to use "gpupdate /force" from the cmd on the machine where DataGateway installed.
    After group policy were updated the problem disappeared.

  • Anonymous's avatar
    Anonymous
    Not applicable

    I am also getting the same error message.

     

    My data sources: Dynamics 365, two Excel spreadsheets (not tables) in Sharepoint/One Drive for Business, and a web page.

     

    As I understand it, it's only the web page that has me needing the gateway at all. In any case, I can set up all my connections in the gateway, and it seems satisfied with the credentials I provide (anonymous for the web page, OAuth for the others). But when it comes time for the schedule refresh, the gateway spins for a long time and then returns this error.

     

    I have the on-premises gateway installed, and I've never had any other gateway installed on this machine (it's a virtual machine in AWS, set up specifically for this purpose).

     

    Based on an earlier suggestion in this thread, I looked at my gateway logs. They're just line after line of "Pool cleaner connections removed," whatever that means.

  • Mamerion's avatar
    Mamerion
    Frequent Visitor

    same problem here.

    updated the gateway to the latest i.e Sep 2018; refreshed the report in Desktop and re-published it on the Service, still getting the same error message.

    referred to the log files on the server and found the follwoing

     

    UserName: MyAdminAccount
    MachineName: ServerName
    
    
    EAD7B167 [DM.EnterpriseGateway] Starting On-premises data gateway service
    [DM.GatewayCore] Setting thread pool worker threads = 300, min completion port threads = 300
    9D1FD689 [DM.GatewayServiceHost] Starting direct query pool if necessary.
    [DataMovement.PipeLine.MashupCommon] Mashup Container Pool DirectQueryPool created.
     [DM.GatewayServiceHost] Direct query pool created True.
    [DM.GatewayServiceHost] Starting test connection pool if necessary.
    [DataMovement.PipeLine.MashupCommon] Mashup Container Pool TestConnectionPool created.
    [DM.GatewayServiceHost] Test connection pool created True.
    [DataMovement.PipeLine.MashupCommon] Mashup Test Connection Settings - TestConnectionTimeout: 00:00:50.
    [DataMovement.PipeLine.MashupCommon] Mashup Engine Container Settings - ContainerMaxCount: 6. ContainerMaxWorkingSet: 256MB. ContainerTimeToLive: 
    [DM.GatewayServiceHost] MashupCustomConnectors = True
    [DataMovement.PipeLine.MashupCommon] SetMashupConnectorsProviders: instantiate memory provider with extensions developed for gateway
    [DataMovement.PipeLine.MashupCommon] Mashup extension file (R, powerbiextensions.r.mez) exists. Start loading.
    [DataMovement.PipeLine.MashupCommon] Mashup extension file (Python, powerbiextensions.python.mez) exists. Start loading.
    [DataMovement.PipeLine.MashupCommon] SetMashupConnectorsProviders: instantiate PowerBIExtensions assembly
    [DataMovement.PipeLine.MashupCommon] SetMashupConnectorsProviders: instantiate filesystem provider at C:\Users\MyAdminAccount\Documents\Power BI Desktop\Custom Connectors, expanded: C:\Users\MyAdminAccount\Documents\Power BI Desktop\Custom Connectors
    [DataMovement.PipeLine.MashupCommon] MashupLibraryProvider filesystem provider did not start. Reason: The directory name C:\Users\MyAdminAccount\Documents\Power BI Desktop\Custom Connectors is invalid.

    I am not using any custom connector; so why it is set to True in Mashup engine?

     

    I ended up un-installing and then re-installing the latest version of the gateway to overcome the issue.

    • Anonymous's avatar
      Anonymous
      Not applicable

      Hi all,

       

      I had a call with Microsoft, they asked me to put privacy level to PRIVATE in the desktop, re-publish, then set privacy = PRIVATE in the PBI online service too (in the gateway settings we're using).

       

      It solved the issue.

       

      Cheers,

       

      F.

      • craigh's avatar
        craigh
        New Member

        Thanks Anonymous - worked a treat!

  • PROBLEM

    My day started with error during refresh via gateway:

     

    {"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"An error happened while reading data from the provider: 'Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).'"}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourceKind","detail":{"type":1,"value":"MySql"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourcePath" ...

     

    I tried all recomendations above, nothing helped in the begining.

     

    STEPS I DID TO SOLVE

    1. Refresh stopped working even from power bi desktop. Got error  
      1. I renewed to Power bi desktop [Version: 2.79.5768.721 64-bit (2020 m. kovas)]    (didn't help)
      2. Added OldGuids=true in  
        • Source = MySQL.Database("xxxxx", "dwhdb", [ReturnSingleDatabase=true,OldGuids=true])   (this solved me refresh in power bi desktop, but refresh via gateway was still failing)
    2. At this moment Refresh via gateway didn't complain about Guid, the error was 
      • {"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[],"exceptionCulprit":1}}} Table: Products Data

    Finally I remembere doing mysql 8 config changes for ETL tools.

     

    [mysqld]
    sql_mode=''
    character_set_server=utf8mb4
    character_set_filesystem=utf8mb4
    collation_server=utf8mb4_0900_ai_ci
    #character-set-client-handshake=FALSE
    init-connect = 'SET NAMES utf8mb4'
    innodb_read_io_threads=8
    innodb_write_io_threads=8
    local_infile=1
    disable_log_bin

     

    What caused issue for me was character-set-client-handshake=FALSE. I commented it out and it started working again.

    I also undone step removed OldGuids=true, which was no longer necessary. And all started working again.

     

    CONCLUSION

    For me it was caused by MySQL 8 character set configuration. So if you have issue - you may want to revisit your configs of the data source.

     

  • I am facing this issue right now.  I cannot create a new DataFlow then using OData. When I enter in the URL to connect to, which is an Azure DevOps URL, and I use the Organiztion Account as the Authentication Kind, when I click Sign In it just hangs on the MashupEditor page with a spinning icon. I have cleared browser cache and check the status of my data source and it shows as Online. This is happening to 3 other co-workers too. So it's not just my account. I can get to the Azure DevOps URL I am using in the OData statement in a different tab of Chrome but I cannot get the Mashup editor to respond.

     

    What are some suggestions to resovle this?