Forum Discussion

ElliotP's avatar
ElliotP
Icon for Post Prodigy rankPost Prodigy
9 years ago
Solved

SQL Connection Named Pipes Provider, error:40

Morning,

 

In the past few days I've been having this issue more and more wherein I'm sometimes able to connect to my sql server when I refresh or apply my queries. In the past I was able to work around this by just running the query again; but I'm trying to run some queries over slightly larger datasets (200k rows) and it seems to fail before it completes.

 

I'm not sure how to enable remote connection on my Azure Sql Database in SSMS or through the azure portal so this might be helpful if anyone knows how.

 

I've allowed the port 1433, I've placed an exception for powerbi through Windows firewall. I've tried to run a telnet but my cmd didn't recognise the command.

 

Thoughts?

 

 

 

 

 

 

 

8 Replies

  • v-qiuyu-msft's avatar
    v-qiuyu-msft
    Icon for Community Support rankCommunity Support

    Hi ElliotP,

     

    1. Please check if the outbound traffic over port 1433 port is allowed on the machine which has desktop runs.

    2. Please add firewall rules to specify which IP address ranges from the Internet are allowed. See: Azure SQL Database server-level and database-level firewall rules.

    3. Please enable Telnet Client feature then run telnet command in cmd. See: Windows 7: Enabling Telnet Client.

     

    Best Regards,
    Qiuyun Yu

    • ElliotP's avatar
      ElliotP
      Icon for Post Prodigy rankPost Prodigy

      Evening, 

       

      Thank you so much for the quick response. I added the port and it seems to be running a lot more comfortably; thank you so much.

      • aghonaim's avatar
        aghonaim
        Icon for Most Valuable Professional rankMost Valuable Professional

        So where did you add the ports exactly ? and what ports # ?

  • PowerLacey's avatar
    PowerLacey
    Regular Visitor

    I got this error because I was entering my server name slightly wrong.  So, if you do all of the technical stuff and it isn't working...check the exact server name.