Forum Discussion

Anonymous's avatar
Anonymous
Not applicable
9 years ago
Solved

The server name provided doesn't match the server name on the SQL Server SSL certificate.

Hi all, can You help me with the next issue? When I refresh data from PowerBI.com using the On-Premises Gateway appears the next message: The server name provided doesn't match the server name on the SQL Server SSL certificate.)

 

I have reinstalled the On-Premises Gateway, reboot SQL services, but message continues appear

 

 

Best regards

  • Anonymous's avatar
    Anonymous
    9 years ago

    Anonymous See this thread you may need to use the Fully Qualified Domain Name. This error indicates to me that this is just a wrong connection string as opposed to something wrong with the gateway setup.

5 Replies

  • Anonymous's avatar
    Anonymous
    Not applicable

    Anonymous See this thread you may need to use the Fully Qualified Domain Name. This error indicates to me that this is just a wrong connection string as opposed to something wrong with the gateway setup.

    • Anonymous's avatar
      Anonymous
      Not applicable

      Thank for your response, I have installed ADO.NET and set in PowerBI.com SERVERNAME.contoso.com\DBInstance as server name in gateway connection all good but when I want to set that DataSource to refresh data in Gateway connection, doesn't appears, I need to reinstall the on-premises gateway?

       

      Best regards

      • Anonymous's avatar
        Anonymous
        Not applicable

        To answer my question, if in Gateway configuration in PowerBI.com set: SERVERNAME.contoso.com\DBInstance, the same server name need to set in the Source configuration in PowerBi Desktop

         

        Regards

  • RaoMohsin6054's avatar
    RaoMohsin6054
    Frequent Visitor

    To resolve the SSL certificate error in Power BI, create an environment variable PBI_SQL_TRUSTED_SERVERS with your SQL Server's name, then restart Power BI. This bypasses the server name mismatch issue.

    Refer to the article