Forum Discussion

rashidanwar's avatar
rashidanwar
Icon for Advocate II rankAdvocate II
5 years ago
Solved

Authentic to host using method ''mySql_native_password' failed: Plugin 'unix_socket' is not loaded

Hi everybody,  I am getting an error while connecting to mySql database Here is the full error message I see when I refresh the power BI desktop report. "MySQL: Authentication to host 'xxx.xxx.x...
  • rashidanwar's avatar
    5 years ago

    Thank you Ibendlin for your response. This problem was resolved as follow.
    Context of the problem: I changed my lapptop and after installing the power BI on new laptop I did face this problem. 

    Later I came to know that, when we install power BI, credentials in the Data Source Setting are set to windows by default. So I changed them to Database by going to
    Home => Transform data => Data Source Setting => Edit Permissions => Edit => Database and then provide your database credentials there, hit the SAVE button and you are DONE!