Forum Discussion
Fabrick - write to lakehouse - get error 24596 when accesssing table using sql afterwards
Hi DavidResolvo ,
Thanks for using Fabric Community.
SQL error number 24596 means that the database is trying to access a file that does not exist. In this case, the database is trying to access the table dbo.Source_D365_LH_CustInvoiceTrans, but the file does not exist.
This error can occur if the table was deleted and the database has not been updated yet.
Can you please explain me how are you creating this table?Are you using the COPY command to create this table? If yes please send me the screenshot of the code. Where is the metadata getting updated?
This information can help me understand the issue better.
Thanks.
Hello sir. Thanks for replying so fast.
We are using the Fabric copy function.
As for your queston: "Where is the metadata getting updated?" -
the symptom is, that I update the data in the lakehouse, and try assessing using the sql endpoint the second after - I get the error 24596. If I wait a minute or two, then it works as expected.
Again thanks for helping. It is apprecidated.
br David
- rubenstolk2 years agoRegular Visitor
- Anonymous2 years agoNot applicable
Thanks for the updates DavidResolvo , rubenstolk ,
Apologies for the issue you have been facing.
We are reaching out to the internal team to get more information related to your query and will get back to you as soon as we have an update.
Appreciate your patience.