Forum Discussion
Fabrick - write to lakehouse - get error 24596 when accesssing table using sql afterwards
Hi DavidResolvo ,
Thanks for using Fabric Community.
SQL error number 24596 means that the database is trying to access a file that does not exist. In this case, the database is trying to access the table dbo.Source_D365_LH_CustInvoiceTrans, but the file does not exist.
This error can occur if the table was deleted and the database has not been updated yet.
Can you please explain me how are you creating this table?Are you using the COPY command to create this table? If yes please send me the screenshot of the code. Where is the metadata getting updated?
This information can help me understand the issue better.
Thanks.
Hi DavidResolvo ,
We haven’t heard from you on the last response and was just checking back to see if you have a resolution yet. Please let me know if you have any other questions.