Forum Discussion

Anonymous's avatar
Anonymous
Not applicable
2 years ago
Solved

Fabric Data Pipeline fails with "LSROBOTokenFailure" error

Previously my PL was running without this error.

{
"RunId": "2b0842be-506a-4811-b7dc-a7e863382796",
"IsCompleted": false,
"EntityName": null,
"Status": "Fail",
"FailureType": "UserError",
"Message": "BadRequest Error fetching pipeline default identity userToken, response content: {\n \"code\": \"LSROBOTokenFailure\",\n \"message\": \"AADSTS50173: The provided grant has expired due to it being revoked, a fresh auth token is needed. The user might have changed or reset their password. The grant was issued on '2024-06-06T23:11:27.0960837Z' and the TokensValidFrom date (before which tokens are not valid) for this user is '2024-06-11T10:38:53.0000000Z'. .........

Im not aware of any password changes etc. I also recreated the PL in stages and it seemed to work ok until I included an Invoke PL activity for an exisitng PL and the failure moved and occured on that Invoke PL Activity.

Any help solving this appreciated.

  • Anonymous's avatar
    Anonymous
    2 years ago

    It seems "tickling" and saving the PL by a minor edit solves the issue.

15 Replies

  • Anonymous's avatar
    Anonymous
    Not applicable

    It seems "tickling" and saving the PL by a minor edit solves the issue.

    • Thania's avatar
      Thania
      Regular Visitor

      ok. Thank you.  But I have various pipeline and it is difficult to enter each one 😞  I will hope that support solvents it of another way.

    • Cobra77's avatar
      Cobra77
      Icon for Post Patron rankPost Patron

      it worked for me too , thanks , but this is not practical with many pipelines to rework

    • Anonymous's avatar
      Anonymous
      Not applicable

      Hi Anonymous 
      Glad that your query got resolved. Please continue using Fabric Community for any help regarding your queries.

      • Anonymous's avatar
        Anonymous
        Not applicable

        It is still a bug in my view so will this be investigated? A work arround is not a solution.

  • Liszet's avatar
    Liszet
    Regular Visitor

    This is still an issue as of 2025-06-06. We have a colleague that quit and a pipeline was still failing even though the connections were in order. I had to make a small edit and save in order for the pipeline to work again.

    • scone's avatar
      scone
      Regular Visitor

      I love you ðŸ’“

  • deshtehari's avatar
    deshtehari
    Regular Visitor

    It's almost a year past from the original report, and still no contribution from the Fabric team!

    Anonymous Can you unmark the workaround as a solution.

  • jeni_nhs's avatar
    jeni_nhs
    Regular Visitor

    As of 2026-05-05 this is still an issue. Tickling the pipeline as suggested resolved the error.

     

    The pipeline was built by someone who left, but I had taken over ownership of it before they did.

    • sdaelemans's avatar
      sdaelemans
      New Member

      Indeed.. We also are facing this many times. Can Microsoft please fix this?...