Forum Discussion
Error connecting to Snowflake which is in "Auto-Enabled" State
- 1 year ago
Hi aswaledeepak,
Happy to see you here in the Microsoft Fabric Community!
Based on the error you're encountering, it appears that Microsoft Fabric's Dataflow Gen2 cannot automatically resume a suspended Snowflake warehouse, even when "Auto Resume" is enabled. This issue is specific to Fabric, as other enterprise applications typically trigger the auto-resume process successfully. Currently, Fabric requires the Snowflake warehouse to be in an active (resumed) state before establishing a connection.
As a workaround, we recommend manually resuming the warehouse before running your Dataflow or setting up an automated process, such as a scheduled Snowflake task or external trigger using Azure Logic Apps to resume the warehouse shortly before the Dataflow refresh. Additionally, reviewing your Snowflake auto-suspend timing to ensure it aligns with your data refresh schedule is advisable.
Solved: Re: Data flow gen 1 and gen2 to Snowflake error wa... - Microsoft Fabric Community
This limitation is not fully documented, and Microsoft may be working on a fix. If needed, you may also consider submitting a support request to Microsoft to help prioritize the feature.If my response was helpful, consider clicking "Accept as Solution" and give us "Kudos" so that other community members can find it easily. Let me know if you need any more assistance!
Thank you.
Hi aswaledeepak,
Just wanted to check regarding your question. We haven’t heard back and want to ensure you're not stuck. If you need anything else or have updates to share, we’re here to help!
If the previous reply resolved your issue, please consider marking it as Accepted and giving it a Kudos to help others find it easily.
If it's resolved, feel free to hit Accept as Solution and drop a Kudos.
Hi aswaledeepak,
We wanted to check if you had a chance to review our last reply. Let us know if it helped or if you need more guidance, we're always happy to help further.
If the solution worked for you, please click Accept as Solution and feel free to leave a Kudos for visibility.
Looking forward to hearing from you!