Forum Discussion

AyusmanBasu0604's avatar
7 months ago
Solved

Fabric SQL Endpoint Issue

My Fabric SQL Endpoint isn't working when trying to connect from Data Agent, So when I ran a query in the endpoint I am getting the following error: Any suggestions on how to resolve this? I am already a Workspace Admin.

Msg 24551, Level 18, State 40, Line 1
 Encountered operating system error 5(Access is denied.) while attempting to read physical metadata.
 Msg 15806, Level 0, State 1, Line 1
 Statement ID: {<statement_ID>} | Query hash: 0x246600F077457920 | Distributed request ID: {68AAA0D5-EB6B-48F3-B237-6A19221ABB6F}
  • Srisakthi's avatar
    Srisakthi
    7 months ago

    Hi AyusmanBasu0604 ,

     

    This could be because of the owner of the item is no longer available in the tenant. Can you try changing the ownership to you.

     

    Regards,

    Srisakthi

4 Replies

  • you were right Srisakthi it was due to an owner who's no longer part of the tenant. After ownership change it's back to normal. Thanks!

  • Hi AyusmanBasu0604 ,

     

    Are you facing this issue on Fabric SQL database sql endpoint or Warehouse SQL endpoint?

     

    Regards,

    Srisakthi

      • Srisakthi's avatar
        Srisakthi
        Icon for Super User rankSuper User

        Hi AyusmanBasu0604 ,

         

        This could be because of the owner of the item is no longer available in the tenant. Can you try changing the ownership to you.

         

        Regards,

        Srisakthi