Forum Discussion

SafMS's avatar
SafMS
New Member
1 month ago
Solved

Unable to create Eventhouse

I'm an admin on Fabric and am working on the End-to-End Real-time intelligence tutorial. The following screenshot of my Fabric Capacity Metric app is showing statitics with high capacity usage for three workspaces that have been deleted more than 40 hours ago:

From Capacity Metric Compute tab:

From Health tab:

 

Even more than 40 hours after deleting those 3 workspaces with hig capacity issue, I'm still getting following error when trying to create an Eventhouse:

Eventhouse item could not be created because your capacity has reached its maximum limit. Contact the capacity administrator for help.

 

Can someone please help resolve the issue?

 

 

  • RESOLVED. As shown below, the Throttling and Interactive rejected capacities are zero now. The issue could have also been related to that the capacity was initially set to F4 and not F64 - or maybe the Throttling and Interactive rejected capacities were cleared after 48 hours were passed:

    Thanks to v-sathmakuri and Asmita_27 for contributing their insights, as well.

3 Replies

  • v-sathmakuri's avatar
    v-sathmakuri
    Icon for Community Support rankCommunity Support

    Hi SafMS ,

     

    Thank you for reaching out to fabric community.

     

    Deleting a workspace does not always free capacity resources immediately. Capacity Metrics can also show historical usage for up to 48 hours, so the deleted workspaces appearing in the report is expected. However, if you're still unable to create an Eventhouse after more than 40 hours, try the following:

    1. Wait up to 48 hours to allow capacity metrics and backend cleanup to complete.
    2. Verify that there are no remaining Real-Time Intelligence artifacts (such as Eventstreams, KQL Databases, Eventhouses, or mirrored items) associated with those workspaces.
    3. Check the Fabric Capacity Metrics app and the Fabric Admin Portal for current active workloads and ensure the capacity hasn't reached its item or compute limits.

    Thanks!!

  • Hi SafMS ,

    We've seen a similar issue before. Please check if Item Recovery (soft delete) is enabled, as deleted workspaces/items may still be retained and continue consuming capacity. If the workspaces were deleted more than 40 hours ago and capacity usage is still not released, you may need to raise a Microsoft support ticket as backend cleanup might be required to fully remove the retained/orphaned items.

    Hope this helps.

  • RESOLVED. As shown below, the Throttling and Interactive rejected capacities are zero now. The issue could have also been related to that the capacity was initially set to F4 and not F64 - or maybe the Throttling and Interactive rejected capacities were cleared after 48 hours were passed:

    Thanks to v-sathmakuri and Asmita_27 for contributing their insights, as well.