Forum Discussion
Fabric - semantic model performance
thank you
I have a follow up questions
1)
looking at one of my tables in the semantic model
the table is sourced from a view in the warehouse (as I understand direct lake is not supported for views. But why do the property (storage mode) say "Direct Lake"?
2)
if I have a model with a mix of direct lake (tables) and direct query (views)
will queries that only consumes direct lake objects use direct lake or is it all or nothing for a semantic model?
1) I don't know, perhaps a bug in the user interface?
2) I believe only visuals which use the View will fall back to DirectQuery. Other visuals should be unaffected and keep using Direct Lake.
This can be tested, if you turn on "Direct Lake Only", then you will see the DirectQuery visuals failing.
Or you can open the reports in Power BI Desktop, and use performance analyzer to check for a DirectQuery activity.
If some visuals fall back to DirectQuery, then that is probably the biggest performance issue.
Here I am using Performance analyzer in Power BI desktop to query a table and also a similar view. The view causes a fallback to DirectQuery.
- joakimfenno1 year ago
Helper V
thanks, I get results like below even thought all tables accessed by the query are tables
- frithjof_v1 year ago
Community Champion
Perhaps the query is just too big, then it falls back to DirectQuery.
Did you enable SQL granular permissions on any of the tables? In that case, it may fall back to DirectQuery.
Did you try using the "Direct Lake Only" setting?
- joakimfenno1 year ago
Helper V
I tried direct lake only but that gives me error message wven though this specific report/visual do not consume anything other than tables
no granular permission (only full on model level) are used