Forum Discussion
TWorku
10 months agoFrequent Visitor
Schema Mismatch on Mirror database from SQL Server
Hi everyone, I’m having trouble with a mirrored database from SQL Server 2017. The initial synchronization works fine, but when the source data updates, I get a schema mismatch error. After c...
- 10 months ago
The Alter command cannot be used on a mirrored database due to its read-only state.
Thank you to lbendlin and v-venuppu for trying to help. The issue has been resolved by:
Disabling and re-enabling CDC on the source database.
Re-enabling CDC on all tables one by one.
Creating a new connection with the latest gateway.
Establishing a new database mirror.
The solution has been stable and monitored successfully for the last four days
lbendlin
Super User
10 months agoThe "not null" is not your issue. Your issue is that Fabric doesn't support auto increment primary keys.